收藏本站 | RSS订阅 股写网-提供股票公式大全,股票公式,公式下载,指标公式
通达信公式 正文

通达信大顶小顶指标公式

时间:2019年12月26日 | 栏目:通达信公式 | 评论:0 | 点击: 168

通达信公式大顶小顶

N:=60;
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=VAR2/VAR1*100-70;
VAR5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=SMA(VAR3/VAR1*100,3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VARA:=IF(VAR9>100,VAR9-100,0);
VARB:=HHV(HIGH,34);
AA:= VARA*2;
BB:= EMA((VAR6-VAR8)/(VARB-VAR8)*100,13);
VARC:=EMA(0.667*REF(BB,1)+0.333*BB,2);
CC:= SMA(VAR5,20,1);
VARD:=SMA(AA,2,1)-AA;
VARE:=EMA(0.667*REF(BB,1)+0.333*BB,2)-BB;
VAR1A:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2A:=SMA(VAR1A,9,1)+100;
VAR3A:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4A:=SMA(VAR3A,3,1);
VAR5A:=SMA(VAR4A,3,1)+100;
VAR6A:=VAR5A-VAR2A;
S: IF(VAR6A>N,VAR6A-N,0);
STICKLINE(BB-VARC>0,BB,VARC,5,0),COLORRED;
STICKLINE(BB-VARC<0,BB,VARC,5,0),COLORFFCCCC;
STICKLINE(CC-SMA(CC,5,1)>0,CC,SMA(CC,5,1),5,0),COLORYELLOW;
STICKLINE(CC-SMA(CC,5,1)<0,CC,SMA(CC,5,1),5,0),COLORBLUE;
STICKLINE(REF(S,1)>S,S,REF(S,1),5,0),COLORFFCC66;