收藏本站 | RSS订阅 股写网-提供股票公式大全,股票公式,公式下载,指标公式
通达信公式 正文

通达信波段操作公式源码

时间:2020年01月20日 | 栏目:通达信公式 | 评论:0 | 点击: 103

n:=100;m:=10;

  RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
VAR1:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VAR5:=CROSS(VAR4,10) AND VAR3<N;
危机线: 80,COLORRED,POINTDOT,LINETHICK2;
中间线: 50,COLORFFCCCC,POINTDOT,LINETHICK2;
全线: 10,COLORFF00FF,POINTDOT,LINETHICK2;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=LLV(LOW,M);
VAR8:=HHV(HIGH,M);
VAR9:=EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13);
VARA:=EMA(0.667*REF(VAR9,1)+0.333*VAR9,2);
战术线: VAR9,COLORYELLOW,LINETHICK2;
战略线: EMA(0.382*REF(VAR9,2)+0.618*VAR9,12),COLORBLUE,LINETHICK2;
STICKLINE(VAR9>VARA,VAR9,VARA,6,0),COLORRED;
STICKLINE(VAR9<=VARA,VAR9,VARA,6,0),COLOR00FF00;
VARB:=SUM(IF(CLOSE>REF(CLOSE,7),VOL,IF(CLOSE<REF(CLOSE,7),0-VOL,0)),0);
VARC:=SUMBARS(VOL,CAPITAL);
VARD:=IF(CLOSE>LLV(CLOSE,VARC),1,-1);
VARE:=IF(VARB>LLV(VARB,VARC),1,-1);
VARF:=VARD*VARE;
VAR10:=IF(VARF=-1,1,0);