收藏本站 | RSS订阅 股写网-提供股票公式大全,股票公式,公式下载,指标公式
大智慧公式 正文

大智慧经典版组合副图(和谐源码分享)

时间:2019年12月26日 | 栏目:大智慧公式 | 评论:0 | 点击: 108

公式测试过,没有任何显示的,不知道哪出问题了。


 {组合}{副图}

 
 
VAR2:=IF(((EMA(CLOSE,5))/(EMA(EMA(CLOSE,9),16))<=0.85) AND ((CLOSE)/(REF(CLOSE,1))>0.905) AND ((CLOSE)/(REF(CLOSE,1))<1.05) AND (((VOL)/(CAPITAL))*(100)<5),50,0);
VAR3:=(((-100))*(HHV(HIGH,34)-CLOSE))/(HHV(HIGH,34)-LLV(LOW,34))+100;
VAR4:=(((-100))*(HHV(HIGH,50)-CLOSE))/(HHV(HIGH,50)-LLV(LOW,50))+100;
VAR5:=(((-100))*(HHV(HIGH,70)-CLOSE))/(HHV(HIGH,70)-LLV(LOW,70))+100;
VAR6:=(((CLOSE-MA(CLOSE,34))/(MA(CLOSE,34)))*(100)+10)*(5);
VAR7:=(((CLOSE-MA(CLOSE,50))/(MA(CLOSE,50)))*(100)+10)*(5);
VAR8:=(((CLOSE-MA(CLOSE,70))/(MA(CLOSE,70)))*(100)+10)*(5);
VAR9:=(VAR3+VAR4+VAR5+VAR6+VAR7+VAR8)/(6);
VARA:=EMA(VAR9,3);
VARB:=ABS(VAR6-VAR8);
VARC:=(VAR9+VARB)/(2);
VARD:=((-1))*(EMA((100)*(1-WINNER(CLOSE)),1)-50)+50;
VARE:=VARD+VARC;{分析家公式网www.88gs.com}
VARF:=IF((VAR2>0) AND (VARE<0),200,0);
VAR10:=IF((VARC<0) AND (CLOSE=LLV(CLOSE,5)) AND ((CLOSE)/(REF(CLOSE,1))>0.905) AND ((CLOSE)/(REF(CLOSE,1))<1.05) AND (((VOL)/(CAPITAL))*(100)<5),(-50),0);
VAR11:=IF((VARE<0) AND (VAR10=(-50)),100,0);
VAR12:=MA(CLOSE,3);
VAR13:=(REF(CLOSE,2))*(0.865);
VAR14:=(REF(CLOSE,13))*(0.772);
VAR15:=MIN(VAR13,VAR14);
VAR16:=((100)*(VOL))/(CAPITAL);
VAR17:=MA(CLOSE,13);
VAR18:=IF(((CLOSE-VAR15)/(CLOSE)<0.03) AND ((SUM(VAR16,5))/(5)<1.8),1,0);
VAR19:=IF((VAR18>0) AND ((VAR10<0) or (VAR2>0)),100,0);
VAR1A:=VAR19;
VAR1B:=IF((((VARF>0) AND (VAR11>0) AND ((SUM(((VOL)/(CAPITAL))*(100),5))/(5)<1) or (VAR18>0) AND ((REF(CLOSE,1))/(REF(CLOSE,2))>0.902)) or ((VARF>0) AND (VAR11>0) AND ((SUM(((VOL)/(CAPITAL))*(100),5))/(5)<1) or (VAR18>0)) AND ((VAR10<0) or (VAR2>0)) AND (VAR19<10)),50,0);
VAR1C:=((VARF>0) AND (VAR11>0) AND ((SUM(((VOL)/(CAPITAL))*(100),5))/(5)<1) or (VAR18>0)) AND ((VAR10<0) or (VAR2>0));
VAR1D:=((VARF>0) AND (VAR11>0) AND ((SUM(((VOL)/(CAPITAL))*(100),5))/(5)<1) or (VAR18>0) AND ((REF(CLOSE,1))/(REF(CLOSE,2))>0.902));
VAR1E:=(VAR1C or VAR1D);
G:=MA(CLOSE,80)-(MA(CLOSE,10))/(3);
AAA:=VAR1A AND (CLOSE<G);
VAR2A:=1;
VAR3A:=(((VAR2A)*(CLOSE-MA(CLOSE,33)))/(MA(CLOSE,33)))*(100);
BBB:=((HHV(CLOSE,13))/(CLOSE)>1.15) AND ((HIGH)/(LOW)>1.08) AND CROSS((-30),VAR3);
VAR1BB:=INDEXC;
VAR2B:=MA(VAR1BB,6);
VAR3B:=MA(VAR1BB,24);
VAR4B:=MA(VAR1BB,32);
VAR5B:=MA(VAR1BB,62);
VAR6B:=MA(VAR1BB,105);
VAR7B:=(VAR5B<REF(VAR5B,1)) AND (VAR6B<REF(VAR6B,1)) AND (VAR5B<(VAR6B)*(0.98));
VAR8B:=(VAR4B>(VAR2B)*(1.11)) AND (VAR3B>(VAR2B)*(1.095));
VAR9B:=(VAR2B>(VAR1BB)*(0.95));
CCC:=VAR7B AND VAR8B AND VAR9B AND ((CLOSE)/(COST(8))<=0.8) AND ((CLOSE>OPEN) or (CLOSE<OPEN)) AND ((REF(CLOSE,1)>REF(OPEN,1)) or (REF(CLOSE,1)<REF(OPEN,1)));
VAR1CC:=DMA(CLOSE,((VOL)/(MA(VOL,4)))/(4));
VAR2C:=DMA(CLOSE,((VOL)/(MA(VOL,33)))/(33));
VAR3C:=(((CLOSE-VAR1CC)/(VAR1CC))*(100)<(-11));
VAR4C:=(((VAR1CC-VAR2C)/(VAR2C))*(100)<(-22.3));
VAR5C:=VAR3C AND VAR4C;
DDD:=VAR5C AND ((OPEN>CLOSE) or (OPEN<CLOSE)) AND ((OPEN-REF(CLOSE,1))/(REF(CLOSE,1))>(-0.07)) AND ((REF(CLOSE,1)>REF(OPEN,1)) or (REF(CLOSE,1)<REF(OPEN,1))) AND ((REF(OPEN,2)>REF(CLOSE,2)) or (REF(OPEN,2)<REF(CLOSE,2))) AND ((REF(OPEN,3)>REF(CLOSE,3)) or (REF(OPEN,3)<REF(CLOSE,3))) AND ((REF(OPEN,4)>REF(CLOSE,4)) or (REF(OPEN,4)<REF(CLOSE,4))) AND ((REF(OPEN,5)>REF(CLOSE,5)) or (REF(OPEN,5)<REF(CLOSE,5))) AND ((REF(OPEN,6)>REF(CLOSE,6)) or (REF(OPEN,6)<REF(CLOSE,6))) AND ((REF(OPEN,7)>REF(CLOSE,7)) or (REF(OPEN,7)<REF(CLOSE,7)));
A1:=INDEXC;
A2:=MA(A1,5);
A3:=MA(A1,20);
A4:=MA(A1,30);
B1:=(A4>(A2)*(1.08)) AND (A3>(A2)*(1.055));
B2:=(A2>(A1)*(1.03));
B3:=B1 AND B2;
M1:=MA(CLOSE,5);
M2:=MA(CLOSE,10);
M3:=(M1<M2);
N1:=((M1-CLOSE)/(CLOSE)>(9)/(100));
N2:=((M2-M1)/(M1)>0.05);
N3:=(HIGH>(LOW)*(1.07)) AND (COUNT((HIGH>(LOW)*(1.04)),5)>2);
N4:=(COUNT(M3,7)>=7);
N5:=N1 AND N2 AND N3 AND N4;
EEE:=B3 AND N5;
FF:=((REF(CLOSE,32)-CLOSE)/(REF(CLOSE,32))>=0.385);
FFF:=CCC AND FF;
XAR1:=DMA(EMA(CLOSE,12),((SUM(VOL,5))/(3))/(CAPITAL));
XAR2:=((CLOSE-XAR1)/(XAR1))*(100)+30-((REF(HIGH,13))/(CLOSE)-1.35)*(100);
XAR3:=(((CLOSE-REF(CLOSE,5))/(CLOSE))*(100)<(-9));
当前获利:=WINNER(CLOSE);
大盘涨跌:=(EMA(((INDEXC-MA(INDEXC,10))/(INDEXC))*(100),14)<(-4.9));
无日换手率:=(((MA(VOL,5)-VOL)/(CAPITAL))*(100)<0.8);
量能变化:=((VOL-MA(VOL,21))/(VOL))*(100);
买入信号:=大盘涨跌 AND XAR3 AND (当前获利<0.12) AND DYNAINFO37 AND (量能变化>18);
GG1:=大盘涨跌 AND XAR3 AND (当前获利<0.12) AND DYNAINFO37 AND (量能变化>18);
GGG:=AAA AND GG1;
(((((AAA AND BBB or AAA AND CCC) or AAA AND DDD) or AAA AND EEE) or FFF) or GGG),CoLor00FFFF;