收藏本站 | RSS订阅 股写网-提供股票公式大全,股票公式,公式下载,指标公式
大智慧公式 正文

黄金短战均线(大智慧经典版指标 主图 和谐源码分享)

时间:2019年12月26日 | 栏目:大智慧公式 | 评论:0 | 点击: 205

{黄金短战均线2}{主图}

{P1:0,600,3;P2:0,600,8;P3:0,600,13;P4:0,600,34;P5:0,300,120;P6:0,300,250;}
 
MA1:MA(CLOSE,P1),CoLor00FFFF;
MA2:MA(CLOSE,P2),CoLorFF00FF;
MA3:MA(CLOSE,P3),CoLor00FF00;
MA4:MA(CLOSE,P4),CoLorFFFFFF;
MA5:MA(CLOSE,P5),CoLorFFFF00;
MA6:MA(CLOSE,P6),CoLor0000FF;
VAR2:=EMA((SLOPE(EMA(CLOSE,20),10))*(34)+CLOSE,30);
VAR3:=EMA(VAR2,3);
VAR4:=EMA(VAR3,3);
A1:=COST(95);
A2:=COST(5);
LY:=((A1-A2)*(100))/(A1+A2);
DRAWICON((LY>REF(LY,1)),(LOW)*(0.98),8),CoLor008000;
DRAWTEXT((VAR4>90),(LOW)*(0.95),'★加仓'),CoLor00FFFF;
DRAWTEXT((VAR4>90),(LOW)*(0.99),'★'),CoLor00FFFF;
VAR1:=(HIGH+LOW+OPEN+(2)*(CLOSE))/(5);
HY3:=IF((COUNT((VAR3<20),5)>=1) AND (COUNT((VAR1=LLV(VAR1,10)),10)>=1) AND (CLOSE>=(OPEN)*(1.038)) AND (VOL>(MA(VOL,5))*(1.2)),1,0);
DRAWTEXT(HY3,LOW,'▲买入'),CoLor00FFFF;
VARR1:=((SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1))/(SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)))*(100);
DRAWICON(CROSS(82,VARR1),HIGH,2),CoLor00FFFF;
DRAWTEXT(CROSS(82,VARR1),HIGH,'▲风险↓'),CoLor00FFFF;
EL1:=EMA(LOW,6);
EL2:=EMA((EMA(LOW,34))*(1),2)-0.16;
DRAWICON(CROSS(EL1,EL2),EL1,10),CoLor00FF00;
V1:=REF(CLOSE,1);
V2:=((SMA(MAX(CLOSE-V1,0),6,1))/(SMA(ABS(CLOSE-V1),6,1)))*(100);
DRAWICON(IF(CROSS(81,V2),1,0),(HIGH)*(1.01),11),CoLorFFFFFF;
VAR41:=EMA(((100)*(CLOSE-LLV(LOW,34)))/(HHV(HIGH,34)-LLV(LOW,34)),3);
VAR42:=EMA(((100)*(INDEXC-LLV(INDEXL,34)))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3);
VAR4A:=(REF(VAR41,1)>92) AND (VAR41<92);
DRAWTEXT(VAR4A,HIGH+0.12,'短卖'),CoLor00FF00;
DRAWTEXT(VAR4A,HIGH+0.05,'●'),CoLor00FF00;
{公式描述:移动平均线}
{----注释:    移动平均线
绘制收盘价的P1日、P2日、P3日、P4日移动平均线
P1、P2、P3、P4一般取5日、10日、20日、60日
用法:葛氏八法则
1.短期均线向上穿越长期均线,买入信号
2.短期均线向下跌破长期均线,卖出信号}
{参数自述: }
{------------------ www.guxie.com.cn ------------------}