收藏本站 | RSS订阅 股写网-提供股票公式大全,股票公式,公式下载,指标公式
通达信公式 正文

通达信公式之:经典共振买指标 源码 MACD——KDJ叠加

时间:2020年02月07日 | 栏目:通达信公式 | 评论:0 | 点击: 106

提示:您正在下载的是:通达信经典共振买主图指标 源码 贴图 MACD——KDJ叠加





{经典共振买MACD--KDJ叠加}
HH:=HHV(H,9);
LL:=LLV(L,9);
FG:=(HH-LL)/100;
RSV:=(C-LL)/(HH-LL)*100;
K1:=SMA(RSV,3,1);
DA:=SMA(K1,3,1);
J1:=3*K1-2*DA;
K:K1*FG+LL,NODRAW;
D:DA*FG+LL,NODRAW;
J:=J1*FG+LL;
DRAWBAND(K,RGB(250,0,0),D,RGB(0,180,0));
ZIF:=EMA(C,12)-EMA(C,26);
ZEA:=EMA(ZIF,9);
ZBC:=2*(ZIF-ZEA);
ZJS:=1.25*ZIF-0.25*ZEA;
ZXH:=(ZJS*13*27-27*11*EMA(C,12)+13*25*EMA(C,26))/28,COLORWHITE;
ZPH:=(ZIF*13*27-27*11*EMA(C,12)+13*25*EMA(C,26))/28,COLORYELLOW;
ZQS:=(ZEA*13*27-27*11*EMA(C,12)+13*25*EMA(C,26))/28,COLORCYAN;
ZNX:=(ZXH+ZQS)/2,COLORMAGENTA;
ZJD:=ATAN((ZPH-REF(ZPH,1))/REF(ZPH,1)*100)*180/3.14159;
导向:ZXH,COLORFFFFFF;
平滑:ZPH,COLOR00FFFF;
牛熊:ZNX,COLORFF00FF;
趋势:ZQS,COLORFFFF00;
DRAWKLINE(H,O,L,C);
NL:=(VOL+REF(V,2)+REF(V,3)+REF(V,4)+REF(V,5))/3.3;
XG1:=V>NL AND REF(J1<50,1) AND CROSS(K,D) AND CROSS(ZXH,ZQS);
XG2:=V>NL AND REF(J1<50,1) AND CROSS(K,D) AND ZXH>ZPH AND ZXH>REF(ZXH,1);
DRAWTEXT(XG1 OR XG2,L,'←共振买'),COLORRED;
{=======================================================}
所属地域:DRAWTEXT_FIX(1,0.005,0.05,0,DYBLOCK),COLORWHITE;
所属行业:DRAWTEXT_FIX(1,0.005,0.1,0,HYBLOCK),COLORWHITE;
所属概念:DRAWTEXT_FIX(1,0.005,0.15,0,GNBLOCK),COLORWHITE;
SSTS:=STRCAT(STRCAT('上市:',CON2STR(FINANCE(42)/1,0)),'天');
LTSZ:=STRCAT(STRCAT('流通市值:',CON2STR(FINANCE(40)/100000000,0)),'亿');
YSTB:=STRCAT(STRCAT('营收同比:',CON2STR(FINANCE(44)/1,2)),'%');
LRTB:=STRCAT(STRCAT('利润同比:',CON2STR(FINANCE(43)/1,2)),'%');
DRAWTEXT_FIX(1,0.005,0,0,SSTS),COLORWHITE;
DRAWTEXT_FIX(1,0.085,0,0,LTSZ),COLORWHITE;
DRAWTEXT_FIX(1,0.185,0,0,YSTB),COLORWHITE;
DRAWTEXT_FIX(1,0.285,0,0,LRTB),COLORWHITE;
净资收益率:=(FINANCE(33)/FINANCE(34)*100);
主营利润率:=(FINANCE(23)/FINANCE(20)*100);
主营业增长率:=FINANCE(44);
每股净资产:=CONST(FINANCE(34));
每股收益:=CONST(FINANCE(38));
净利润增长率:=FINANCE(43);
市销率:=CONST(FINANCE(1)*DYNAINFO(7)/FINANCE(20));
现金负债比:=(FINANCE(25)/FINANCE(15));
每股未分配:=CONST(FINANCE(32));
每股公积金:=CONST(FINANCE(18));
SY01:=净资收益率>3;
SY02:=净资收益率>0.01 AND 净资收益率<=3;
SY03:=主营利润率>2;
SY04:=主营利润率>0;
SY05:=主营业增长率>1;
SY06:=主营业增长率>0;
SY07:=净利润增长率>2;
SY08:=净利润增长率>0.2;
SY09:=每股收益>0.01;
SY10:= 每股收益>0.001;
SY11:=每股净资产>2;
SY12:=每股净资产>0.01;
SY13:=每股未分配>0.5;
SY14:=每股未分配>0.001;
SY15:=每股公积金>0.5;
SY16:=每股公积金>0.002;
SY17:=每股未分配>=2 AND 每股公积金>=2;
SY18:=每股未分配<2 OR 每股公积金<2;
优秀:=SY01 AND SY03 AND SY05 AND SY07 AND SY09 AND SY11
AND SY13 AND SY15;
较好:=SY02 AND SY04 AND SY06 AND SY08 AND SY10 AND SY12
AND SY14 AND SY16;
一般:=NOT(优秀) AND NOT(较好);
DRAWTEXT_FIX(优秀 AND 较好=0,0.45,0,0,'综合评估基本面:优秀!'),COLORMAGENTA;
DRAWTEXT_FIX(较好,0.45,0,0,'综合评估基本面:较好!'),COLORRED;
DRAWTEXT_FIX(一般,0.45,0,0,'综合评估基本面:一般!'),COLORGREEN;
DRAWTEXT_FIX(SY17,0.65,0,0,'是否具备高送转潜力:是!'),COLORMAGENTA;
DRAWTEXT_FIX(SY18,0.65,0,0,'是否具备高送转潜力:否!'),COLORGREEN;